Webapp and API Unavailable

Incident Report for Clarify

Resolved

This incident has been resolved.
Posted May 21, 2026 - 14:55 PDT

Update

Web application and API are back online now, expect data delays as we process emails and meetings.
Posted May 21, 2026 - 14:54 PDT

Investigating

We are currently aware of the issue and are investigating
Posted May 21, 2026 - 14:03 PDT
This incident affected: Web Application and API.